

I don’t think it’s self-signed… I used Caddy to generate the certs and copied them over into the config for the service. The service2 that I’m unable to access is ActualBudget and I followed their instructions from their docs (https://actualbudget.org/docs/config/https)
Thanks for the explanation! I removed the entries for the certs in Actual and now it seems to be working. Solved a problem and learned something new!